ALS.FOUT | Zo werkt de formule en hier gebruik je het voor

De formule als.fout zorgt ervoor dat als er een error in de cel zou komen te staan, door een niet goed ingevoerde formule of doordat deze geen uitkomst heeft, er een alternatief in de plaats komt te staan.

Deze formule is handig om een melding weer te geven bij een fout, ├│f zoals ik hem vaak gebruik, een alternatieve berekening in de plaats kan worden gemaakt.

Deze melding wordt alleen weergegeven als er een error in de cel is. Hij lijkt wel een beetje op de als-formule.

Toepassing

De toepassing van de als.fout formule.
=ALS.FOUT(waarde;waarde-indien-niet-juist)

  • waarde: Hier komt gewoon de waarde of formule te staan.
  • waarde-indien-niet-juist: Als de waarde een fout/error aangeeft wordt deze ingevulde waarde weergegeven.

Laten we bijvoorbeeld eens kijken naar een simpele formule die een fout geeft, cel in kolom B gedeeld door cel in kolom C:

Formule die een fout geeft

10 / 0 kan niet en dus krijg je een fout.

Maar hierdoor kun je onderaan ook niet meer het gemiddelde van de kolommen berekenen, omdat er een fout in kolom D staat.

De oplossing is gevonden met de functie ALS.FOUT:

formule als fout in Excel

Het antwoord in cel D3 is nu niet meer #DEEL/O! maar 0. Nu kan vervolgens onderaan ook het gemiddelde van kolom D weer worden berekend.

Wat de formule in wezen doet is de volgende logica:

  • Als de formule in het eerste gedeelte een fout geeft (B3/C3)
  • Doe dan wat er na de ; staat (0)
  • Voer anders gewoon het resultaat uit de formule uit (B3/C3)

Opmerking

  • Als het argument waarde of waarde-indien-niet-juist leeg wordt gelaten, beschouwd Excel dit gewoon als lege waarden.
  • Wanneer je bij het argument een matrix invult, geeft de formule ALS.FOUT een matrix met resultaten weer voor elke cel die opgenomen is in het bereik.

Bijvoorbeeld

Bij dit voorbeeld gebruiken wij de formule vert.zoeken, waarbij de zoekwaarde niet gevonden kan worden.

De verticaal zoeken formule is zo:
=VERT.ZOEKEN(5;A1:B5;2;ONWAAR)
Echter komt het getal 5 niet voor in het bereik, er wordt dus een error weergegeven.

Om dit te voorkomen, en een lege cel weer te geven, maken we de volgende formule:
=ALS.FOUT(VERT.ZOEKEN(5;A1:B5;2;ONWAAR);””)

2 gedachten over “ALS.FOUT | Zo werkt de formule en hier gebruik je het voor”

    • Laten we de twee formules bekijken:

      ALS.FOUT(D4/$B$3*$A$2; “0”)
      Deze formule is correct.
      Hiermee deel je de waarde in cel D4 door de waarde in cel B3, vermenigvuldigd met de waarde in cel A2. Als er een fout optreedt (bijvoorbeeld als de waarde in cel B3 nul is), zal de functie “ALS.FOUT” een nul (“0”) teruggeven.

      ALS.FOUT(D4/$B$3*$A$2); “0”)
      Deze formule bevat een klein foutje in de plaatsing van de haakjes. De haakjes moeten worden verplaatst zodat de formule correct werkt. De juiste versie zou zijn:
      ALS.FOUT(D4/$B$3*$A$2; “0”)

      In deze formule ontbreekt de haakjes aan het einde van de functie “ALS.FOUT”.
      Hierdoor ontstaat er een syntactische fout in de formule, waardoor Excel de formule niet correct kan evalueren.

      Het is belangrijk om altijd op te letten bij het plaatsen van haakjes in Excel-formules. Een goede manier om fouten te voorkomen, is door formules stukje bij beetje op te bouwen en tussentijdse resultaten te controleren om te zien of alles naar behoren werkt.

      Beantwoorden

Plaats een reactie