Als functie in Excel met meerdere voorwaarden | Geneste formule

In deel 1 van onze zelfstudie over de Excel ALS-functie zijn we begonnen de basis van de Excel ALS-functie te leren.

Zoals je je misschien nog herinnert, hebben we enkele ALS-formules besproken voor getallen, datums en tekstwaarden, evenals hoe je een ALS-functie kunt schrijven voor lege en niet-lege cellen.

Voor een krachtige gegevensanalyse moet je echter vaak meerdere voorwaarden tegelijk evalueren, wat betekent dat je meer geavanceerde logische tests moet maken met meerdere ALS-functies in één formule.

De onderstaande voorbeelden van formules laten je zien hoe je dit correct kunt doen.

Geneste ALS formules achter elkaar gebruiken

Een van de mogelijkheden die ik zelf ook nog vaak gebruik, is om meerdere ALS formules achter elkaar te gebruiken. Een voorbeeld daarvan zou kunnen zijn:

=ALS(A1>2;”Boven Twee”;ALS(A1<0;”Onder Nul”;”Nul tot Twee”))

Je moet deze formule zo lezen:

  • Als cel A1 groter is dan 2, geef dan de tekst “Boven Twee” weer
  • Anders als cel A1 kleiner is dan nul, geef dan de tekst “Onder Nul” weer
  • Anders (als aan beide voorwaarden niet is voldaan) geef dan de tekst “Nul tot Twee” weer

Meerdere als formules achter elkaar

Je kunt hiermee formules maken met zoveel =ALS functies erin als je wilt. Hoe meer je er toevoegt, hoe moeilijker het te lezen wordt dus op een gegeven moment is het bijna niet meer bij te houden.

Let ook op dat er aan het einde van deze formule twee “)” staan weergegeven, eentje voor elke ALS formule die we erin hebben opgenomen.

Excel ALS-functie met meerdere EN / OF-voorwaarden

Samenvattend kunnen er 2 basistypen van meerdere voorwaarden zijn, met logica EN en OF. Daarom moet je ALS-functie respectievelijk een EN- of OF-functie in de logische test insluiten.

EN functie

Als je logische test de EN-functie bevat, retourneert Microsoft Excel WAAR als aan alle voorwaarden is voldaan; anders wordt FALSE geretourneerd.

OF functie

Als je de OF-functie in de logische test gebruikt, retourneert Excel WAAR als aan één van de voorwaarden is voldaan; FALSE als aan geen is voldaan.

Om het punt beter te illustreren, laten we een paar ALS-voorbeelden bekijken met meerdere voorwaarden.

Voorbeeld 1: De functie ALS & EN gebruiken in Excel

Stel dat je een tabel hebt met de resultaten van twee examenuitslagen.

  • De eerste score, opgeslagen in kolom C, moet gelijk zijn aan of groter zijn dan 20.
  • De tweede score, vermeld in kolom D, moet gelijk zijn aan of hoger zijn dan 30.
  • Alleen als aan beide bovenstaande voorwaarden is voldaan, slaagt een student voor het examen.

De eenvoudigste manier om een ​​juiste formule te maken, is door eerst de voorwaarde op te schrijven en deze vervolgens op te nemen in het argument logic_test van je ALS-functie:

Dus: EN (B2> = 20; C2> = 30)

ALS / EN-formule: =ALS(EN(C2>=20; D2>=30); “Geslaagd”; “Gezakt”)

Makkelijk toch?

De formule vertelt Excel om “Geslaagd” terug te geven als de waarde in kolom C> = 20 EN de waarde in kolom D> = 30 en dus aan beide voorwaarden is voldaan. Anders retourneert de formule “Gezakt”.

De onderstaande schermafbeelding bewijst dat onze Excel Als/ EN functie correct is:

Als samen met een EN functie voor meerdere voorwaarden

Notitie. Microsoft Excel controleert alle voorwaarden in de EN-functie, zelfs als een van de reeds geteste voorwaarden evalueert als ONWAAR.

Dergelijk gedrag is een beetje ongewoon, omdat in de meeste programmeertalen opeenvolgende voorwaarden niet worden getest als een van de vorige tests FALSE heeft geretourneerd.

In de praktijk kan een ogenschijnlijk correcte ALS / EN-formule een fout veroorzaken vanwege deze specificiteit.

Neem de formule  =ALS(EN (A2<>0;(1/A2)>0,5);”Goed”, “Slecht”)

Deze zal bijvoorbeeld “Delen door nulfout” (#DIV/0!) geven als cel A2 gelijk aan 0. Om dit te voorkomen, moet je een geneste ALS-functie gebruiken:

=ALS(A2<>0;ALS((1/A2)>0,5;”Goed”;”Slecht”);”Slecht”)

Voorbeeld 2: ALS gebruiken met OF-functie in Excel

Je gebruikt de combinatie van ALS & OF-functies op een vergelijkbare manier. Het verschil met de hierboven besproken ALS / EN-formule is dat Excel WAAR retourneert als aan ten minste een van de opgegeven voorwaarden is voldaan.

Dus als we de bovenstaande formule op de volgende manier wijzigen:

=ALS(OF(C2>=20;D2>=30);”Geslaagd”;”Gezakt”)

Kolom E krijgt het “Geslaagd” -teken als de eerste score gelijk is aan of groter is dan 20 OF de tweede score gelijk is aan of groter is dan 30.

Zoals je in de onderstaande screenshot kunt zien, hebben onze studenten een betere kans om het eindexamen te behalen met dergelijke voorwaarden:

Als formule met meerdere voorwaarden en OF

Voorbeeld 3: ALS gebruiken met EN & OF-functies

Als je jouw gegevens moet evalueren op basis van meerdere sets van meerdere voorwaarden, moet je beide EN & OF-functies tegelijkertijd gebruiken.

Stel dat je in de bovenstaande tabel de volgende criteria hebt om het succes van de studenten te evalueren:

  • Voorwaarde 1: kolom C> = 20 en kolom D> = 25
  • Voorwaarde 2: kolom C> = 15 en kolom D> = 20

Als aan één van de bovenstaande voorwaarden is voldaan, wordt het eindexamen geacht te zijn geslaagd, anders – niet geslaagd.

De formule lijkt misschien lastig, maar je zult meteen zien dat het niet zo is! Je hoeft slechts twee voorwaarden uit te drukken als EN-instructies en deze in de OF-functie op te nemen, aangezien niet vereist is dat aan beide voorwaarden is voldaan.

OF (EN (C2> = 20; D2> = 25); EN (C2> = 15; D2> = 20)

Gebruik ten slotte de bovenstaande OF-functie als de logische test in de ALS-functie en voer argumenten waarde_als_waar en waarde_als_onwaar in. Als resultaat krijg je de volgende ALS-formule met meerdere EN / OF-voorwaarden:

=ALS(OF(EN(C2>=20;D2>=25);EN(C2>=15;D2>=20));”Geslaagd”;”Gezakt”)

De onderstaande schermafbeelding geeft aan dat we de formule goed hebben:
Als funtie met EN en OF formules

Natuurlijk ben je niet beperkt tot het gebruik van slechts twee EN / OF-functies in je Excel ALS formules. Je kunt zoveel logische functies gebruiken als jouw bedrijfslogica vereist, op voorwaarde dat:

  • In Excel 2016, 2013, 2010 en 2007 bevat je formule niet meer dan 255 argumenten en de totale lengte van de formule is niet groter dan 8.192 tekens.
  • In Excel 2003 en lager kun je maximaal 30 argumenten gebruiken en de totale lengte van je formule mag niet meer dan 1.024 tekens bevatten.

En dat is alles wat ik te zeggen heb over het gebruik van de ALS-functie in Excel. Bedankt voor het lezen en ik hoop je volgende week op onze blog te zien!

Dit vind je misschien ook leuk...

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *

Spring naar toolbar