Maak een kalender


Version
Download 6
Total Views 42
Stock
File Size 22.56 KB
File Type xlsx
Create Date 9 juni 2018
Last Updated 20 november 2018
Log in om te downloaden

Deze keer kan je de download stap voor stap meemaken. Als je alle stappen goed volgt, dan heb je je eigen mooie kalender gemaakt. Mocht je nu niet veel tijd of zin hebben om hem zelf te maken dan kan je hem hier ook downloaden.
Natuurlijk kan je ook een van de vele sjablonen in excel gebruiken. Maar een eigen gemaakte is toch veel leuker? Bovendien leer je er veel van!
Je kan hem zelf opmaken naar je eigen wensen. Hier wordt wel bepaalde opmaak gekozen, maar dit valt altijd aan te passen.

Omdat ik deze kalender in een leeg werkblad maak, maak ik alle berekeningen gewoon in op dit blad, deze maak ik wit op het einde. Mocht je er ook nog andere gegevens op hebben is het misschien handig om een apart werkblad te maken voor de instellingen.

 

Inhoud

Deze methodes en formules worden toegepast bij de kalender.

 

 

Stap 1

Er wordt vanuit gegaan dat je met een leeg werkblad begint. Als eerst maken we de kalender en waar je het jaar en de maand kan kiezen. Zo weten we hoeveel ruimte we nog over hebben.

Je selecteert bereik B5:H12, hier zetten we eerst als rand Alle randen en daarna Dikke buitenste randen omheen.
De eerste regel, met bereik B5:H5 mag je Samenvoegen en centreren. Ik geef hem ook de opvulling Lichtgroen mee.
Vervolgens zet je in cel B6 Ma, in C6 Di dit doe je door tot in H6 Zo staat. Dit geef ik als opvulling Zwart, Tekst 1 mee. De tekst geef ik de volgende opmaak: Wit, vetgedrukt en gecentreerd.
De weekenddagen geef ik ook nog een apart kleurtje. Het bereik G7:G12, oftewel de zaterdag, maak ik Lichtgrijs, Achtergrond 2, donker 10%. Het bereik H7:H12, zondag, maak ik Lichtgrijs, Achtergrond 2, donkerder 50%.

Daarna maak je nog de velden jaar en maand aan die je straks laat kiezen. Ik kies ervoor om dit in celbereik B2:C3 te gaan doen.
Selecteer dit bereik hier zetten we eerst als rand Alle randen en daarna Dikke buitenste randen omheen.
De bovenste 2 vakken B2 en C2 geef ik de opvulkleur lichtgroen en dit centreer ik.
Dan vul je nog in cel B2 maand en in cel C2 jaar in.

Uitleg voor het maken van een kalender.

Als je de aanwijzing volgde, ziet je kalender er zo uit.

 

Stap 2

In deze stap gaan we zorgen dat je het jaartal en de maand kan kiezen.
Voor de handigheid zet ik in cel B14 even jaar, in C14 maand en D14 nummer.
Selecteer cel B15 en zet hier in 1980. Je kan de kalender tot 1900 maken, dan pas je simpelweg de keuze optie's aan.
Dan in cel B16 1981 en zo verder tot in B55 het jaartal 2020 staat. Ook hier kan je weer verder, dan moet je de keuze hier ook langer maken.
Je kan al de jaartallen handmatig typen, maar je kan ook gebruik maken van de methode reeks doorvoeren.
Maak in cel C15 de invoer januari. Dit werk je ook weer naar beneden bij tot in C26 december staat.
Bij de nummer, D15, zet je het getal 1. Ook hier weer naar beneden tot in D26 het getal 12 staat.

We gaan weer terug naar cel B3 en maken hier een keuzelijst. De keuzelijst bevat hier het bereik C15:C26.
Ook voor C3 gaan we een keuzelijst maken. Selecteer hier bereik B15:B55.

Uitleg hoe je een kalender maakt in excel.

Na het volgen van stap 2 is dit je tussenresultaat.

 

Stap 3

Nu gaan we beginnen met de formules op de achtergrond.
Selecteer cel D3 en zet hier de vert.zoeken formule in die zorgt dat het getal wat achter de maand staat, die je in hebt gevoerd bij stap 2, hier komt te staan.
Zet deze formule in D3: =VERT.ZOEKEN(B3;C15:D26;2;ONWAAR). Je hoeft er geen absolute verwijzing van te maken omdat de formule niet gekopieerd wordt.
In E3 zet je de formule datum en zorg je dat de eerste datum van de opgegeven maand wordt gepakt. De formule: =DATUM(C3;D3;1).
Bij cel F3 pas je de formule weekdag toe. Het serieel nummer is hier E3, die je net aangemaakt hebt, en type_getal is hier 11. Van maandag tot zondag.
In G3 zet je de simpele formule =E3-F3.

Nu ben je met deze formules klaar. Nu wordt het taak om de dagen goed te laten weergeven. Ik heb voor het gemak even een 'nep kalender', hier gaan we bij stap 4 mee aan de slag.

De uitkomst na het succesvol volgen van stap 3.

 

Stap 4

In cel J7 zet je het getal 1. In K7 het getal 2 dit doe je tot in P7 het getal 7 staat.
Dan zet je in J8 de formule J7+7 en deze kopieer je in het bereik J8:P12.
Dit was het stukje formules. Natuurlijk niet de ingewikkelste formules, maar deze helpen jou bij de wat moeilijkere in stap 5.

Als je de stap goed hebt gedaan kom je tot dit resultaat.

 

Stap 5

Hier gaan we de uiteindelijke formules in de kalender maken.
Selecteer B7 en maak daar de volgende formule: =ALS(EN(JAAR($G$3+J7)=$C$3;MAAND($G$3+J7)=$D$3);$G$3+J7;"").
Als deze gemaakt is, kopieer je deze in het bereik B7:H12.
Het wordt nu gevuld met de dagen van de betreffende maand in dat jaar.

Voor de volledigheid zetten we in de Lichtgroene, samengevoegde cel nog even de maand en het jaar.
Dit doen we door in B5 de volgende formule te zetten: =B3&" "&C3

Voor dat ik het eindresultaat laat zien ga ik de formules die alleen maar als hulpmiddel dienen de tekstkleur wit meegeven. De hulptabel formules verberg ik, zodat je alleen de kalender ziet.
Ook het raster zet ik uit.

Het eindresultaat.

 

 

 

Was deze uitleg nuttig? Dan kan je je inschrijven voor onze nieuwsbrief.
Een keer per maand ontvang je de nieuwste berichten in je mailbox.
Klik hier om je in te schrijven!

Dit vind je misschien ook leuk...

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *

Spring naar toolbar