De functie VERSCHUIVING in Excel uitgelegd met voorbeeld

De formule VERSCHUIVING geeft een verwijzing naar een andere cel (of cellen) die een aantal regels of kolommen is opgeschoven.

Je kan hiermee aangeven hoeveel regels of kolommen weergegeven moeten worden.

In het Engels heet de functie OFFSET en retourneert een cel of cellenbereik dat een gespecificeerd aantal rijen en kolommen uit een cel of cellenbereik is.

Toepassing

=VERSCHUIVING(verw;rijen;kolommen;[hoogte];[breedte])

  • Verw: Een verwijzing waarvandaan de verschuiving plaats vindt.
  • Rijen: Aantal rijen dat verschoven is.
  • Kolommen: Aantal kolommen dat verschoven is.
  • Hoogte: De aantal rijen dat weergegeven dient te worden. Dit is niet verplicht.
  • Breedte: De aantal kolommen dat weergegeven dient te worden. Dit is niet verplicht.

Je kan 126 paren van veld en item invullen.

Verschuiving van 1 cel

De onderstaande VERSCHUIVING-functie retourneert de cel die 3 rijen lager is en 2 kolommen rechts van cel A2. De functie OFFSET retourneert een cel omdat de hoogte en breedte beide zijn ingesteld op 1.

Verschuiving functie in Excel

De verschuiving toont nu het resultaat uit cel C2. Deze is vanaf cel A2 gezien:

  • 3 rijen naar beneden
  • 2 kolommen naar rechts
  • bereik van 1 rij hoog
  • bereik van 1 kolom breed

=VERSCHUIVING(A2;3;2;1;1)

Verschuiving van een bereik (meerdere cellen)

De onderstaande Verschuiving-functie retourneert het 1 x 2-bereik dat 8 rijen lager is en 1 kolom rechts van cel A2. De functie SOM berekent de som van dit bereik.

Verschuiving van een excel bereik

Dit is de som van de cellen B10 en C10. Deze is vanaf cel A2 gezien:

  • 8 rijen naar beneden
  • 1 kolom naar rechts
  • bereik van 1 rij hoog
  • bereik van 2 kolommen breed

=SOM(VERSCHUIVING(A2;8;1;1;2))

Opmerking: als je een bereik wilt retourneren (zonder de som te berekenen), selecteer je een bereik van dezelfde grootte voordat je de functie VERSCHUIVING invoegt.

Als je een cel of celbereik wilt retourneren dat een gespecificeerd aantal rijen boven of kolommen links is, voer je een negatief getal in. Dus dat kan ook gewoon.

Opmerking

  • De foutmelding #VERW! wordt weergegeven als de kolommen of rijen die worden verschoven uiteindelijk van het werkblad vallen.
  • Als de hoogte en breedte niet zijn ingevuld, wordt er uitgegaan van de afmetingen bij verw.
  • Met deze formule wordt niks verplaatst, het geeft alleen als resultaat van cellen die verplaatst zijn.

Bijvoorbeeld

Bij dit voorbeeld maken we gebruik van de onderstaande gegevens:

Gegevens
1
5
3
9

Hier passen we de volgende formule op toe:
=VERSCHUIVING(D3;2;-3;1;1)

Dit wil zeggen dat hij bij D3 -3 kolommen verder kijkt (3 terug dus) en 2 regels naar beneden.

Dit vind je misschien ook leuk...

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *