INDEX() en VERGELIJKEN() als alternatief voor VERT.ZOEKEN en meer

Met de combinatie van de formules INDEX en VERGELIJKEN kan je hetzelfde als met de VERT.ZOEKEN formule.

Je kan er zelfs meer mee. Met verticaal zoeken kan je alleen naar rechts zoeken, met een combinatie van index en vergelijken kan je echter naar links en rechts zoeken in een bereik. Bovendien is de formule ook nog sneller.

Toepassing

=INDEX(matrix;rij_getal;[kolom_getal])
=VERGELIJKEN(zoekwaarde;zoeken_matrix;[criteriumtype_getal])

  • Matrix: Een bereik met cellen.
  • Rij_getal: De rij waaruit een waarde wordt gehaald. Als je rij_getal niet invult, is kolom_getal een verplicht in te vullen argument.
  • Kolom_getal: De kolom waaruit een waarde wordt gehaald. Als je kolom_getal niet invult, is rij_getal een verplicht in te vullen argument..
  • Zoekwaarde: Een waarde die je wilt gaan opzoeken.
  • Zoeken_matrix: Het bereik waarin wordt gezocht.
  • Criteriumtype_getal Hoe er gezocht moet worden.
    1 of weggelaten: Hiermee moeten de waarden in zoeken_matrix oplopend zijn gesorteerd.
    0: Zoekt naar de eerste waarde die precies gelijk is aan de zoekwaarde.
    -1: Zoekt naar de kleinste waarde, die wel groter is dan de zoekwaarde.De combinatie zorgt uiteindelijk voor deze formule:
    =INDEX(matrix;VERGELIJKEN(zoekwaarde;zoeken_matrix;[criteriumtype_getal]);[kolom_getal])

    Eigenlijk is dit de formule:
    =INDEX(kolom met data die je zoekt;VERGELIJKEN(waarde waarop gezocht moet worden; kolom waarin de zoekwaarde staat))

    Bijvoorbeeld

    Voorbeeld voor index en vergelijken

    NaamLeeftijdPlaats
    Piet50Tilburg
    Riet74Amsterdam
    Henk32Rotterdam
    Hans44Eindhoven
    Truus55Breda

    Plak de tabel in Excel vanaf cel A1 om dit voorbeeld te volgen.

    In bovenstaand voorbeeld kan je verticaal zoeken toepassen als je op naam zoekt met als uitkomst plaats, je krijgt dan bijvoorbeeld:
    =VERT.ZOEKEN(“Riet”;A1:C6;3;ONWAAR)
    Antwoord: Amsterdam
    Index en vergelijken zorgt voor deze formule:
    =INDEX(C2:C6;VERGELIJKEN(“Riet”;A2:A6;0))
    Antwoord: Amsterdam

    Nu komt het grote verschil. Je wilt opzoeken welke naam bij Amsterdam hoort. Voor verticaal zoeken kom je dan tot deze formule:
    =VERT.ZOEKEN(“Amsterdam”;A1:C6;3;ONWAAR)
    Antwoord: #N/B omdat de waarde niet rechts van de zoekwaarde wordt gevonden
    Index en vergelijken zorgt voor deze formule:
    =INDEX(A1:A6;VERGELIJKEN(“Amsterdam”;C1:C6;0))
    Antwoord: Riet

     

     

     

     

    Nieuwsbrief

    Als deze uitleg nuttig was, dan kan je je inschrijven voor onze nieuwsbrief.
    Een keer per maand ontvang je de nieuwste berichten in je mailbox.
    Klik hier om je in te schrijven.
    Je kan ons ook volgen op Facebook en Twitter.

    Met de combinatie van de formules INDEX en VERGELIJKEN kan je hetzelfde als met de VERT.ZOEKEN formule.

    Je kan er zelfs meer mee. Met verticaal zoeken kan je alleen naar rechts zoeken, met een combinatie van index en vergelijken kan je echter naar links en rechts zoeken in een bereik. Bovendien is de formule ook nog sneller.

    Toepassing

    =INDEX(matrix;rij_getal;[kolom_getal])
    =VERGELIJKEN(zoekwaarde;zoeken_matrix;[criteriumtype_getal])

    • Matrix: Een bereik met cellen.
    • Rij_getal: De rij waaruit een waarde wordt gehaald. Als je rij_getal niet invult, is kolom_getal een verplicht in te vullen argument.
    • Kolom_getal: De kolom waaruit een waarde wordt gehaald. Als je kolom_getal niet invult, is rij_getal een verplicht in te vullen argument..
    • Zoekwaarde: Een waarde die je wilt gaan opzoeken.
    • Zoeken_matrix: Het bereik waarin wordt gezocht.
    • Criteriumtype_getal Hoe er gezocht moet worden.
      1 of weggelaten: Hiermee moeten de waarden in zoeken_matrix oplopend zijn gesorteerd.
      0: Zoekt naar de eerste waarde die precies gelijk is aan de zoekwaarde.
      -1: Zoekt naar de kleinste waarde, die wel groter is dan de zoekwaarde.De combinatie zorgt uiteindelijk voor deze formule:
      =INDEX(matrix;VERGELIJKEN(zoekwaarde;zoeken_matrix;[criteriumtype_getal]);[kolom_getal])

      Eigenlijk is dit de formule:
      =INDEX(kolom met data die je zoekt;VERGELIJKEN(waarde waarop gezocht moet worden; kolom waarin de zoekwaarde staat))

      Bijvoorbeeld

      Voorbeeld voor index en vergelijken

      NaamLeeftijdPlaats
      Piet50Tilburg
      Riet74Amsterdam
      Henk32Rotterdam
      Hans44Eindhoven
      Truus55Breda

      Plak de tabel in Excel vanaf cel A1 om dit voorbeeld te volgen.

      In bovenstaand voorbeeld kan je verticaal zoeken toepassen als je op naam zoekt met als uitkomst plaats, je krijgt dan bijvoorbeeld:
      =VERT.ZOEKEN(“Riet”;A1:C6;3;ONWAAR)
      Antwoord: Amsterdam
      Index en vergelijken zorgt voor deze formule:
      =INDEX(C2:C6;VERGELIJKEN(“Riet”;A2:A6;0))
      Antwoord: Amsterdam

      Nu komt het grote verschil. Je wilt opzoeken welke naam bij Amsterdam hoort. Voor verticaal zoeken kom je dan tot deze formule:
      =VERT.ZOEKEN(“Amsterdam”;A1:C6;3;ONWAAR)
      Antwoord: #N/B omdat de waarde niet rechts van de zoekwaarde wordt gevonden
      Index en vergelijken zorgt voor deze formule:
      =INDEX(A1:A6;VERGELIJKEN(“Amsterdam”;C1:C6;0))
      Antwoord: Riet

       

       

       

       

      Nieuwsbrief

      Als deze uitleg nuttig was, dan kan je je inschrijven voor onze nieuwsbrief.
      Een keer per maand ontvang je de nieuwste berichten in je mailbox.
      Klik hier om je in te schrijven.
      Je kan ons ook volgen op Facebook en Twitter.

Dit vind je misschien ook leuk...

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *

Spring naar toolbar